PDA

View Full Version : Deceptive Character Limit


Darryl
09-27-2002, 04:40 PM
Hi Guys,

Just wanted to pass along a little bug I just encountered.

In posting a new thread (this one (http://www.geekvillage.com/forums/showthread.php?s=&threadid=18675)), I was running into the 10,000 character limit. While I have no problem with the limit itself (I just had to cut out my commentary - and you'd think 10,000 characters would be more than enough), the "check message length" link doesn't seem to calculate properly.

The issue arises because the "check message length" link doesn't account for the parsing of URLs...so when I checked the message length and it said 9,995 characters, it didn't account for the "" and "" it needed to add, which sent it over the 10k limit.

And, of course, to top it all off, when I tried posting the article at what I thought was 9,995 characters, vBulletin gave me an error message, saying it was over the 10k limit.

Here's the real kicker, though - there was no "Go back and edit" link in that error message, so I was forced to use the back button. And what happened when I used the back button? That's right, it wiped out all the contents of the message post form.

Could you imagine if I'd actually typed the whole thing and not just cut & paste?

Anyway, thought I'd let you guys know.

Steve_S
09-28-2002, 11:52 AM
Hi Darryl,

Thanks for the bug report. I will let the developer know about this and sorry for any inconvenience this may have caused you.

:angel: