View Single Post
Old 07-29-2001, 06:47 PM   #25
darnell
Registered User
 
darnell's Avatar
 
Join Date: Mar 2001
Location: Suwanee, GA, USA
Posts: 704
Default

I've tried a .htaccess file with the following

--------------------------------------
# block offline browsers
RewriteEngine on
RewriteCond %{HTTP_USER_AGENT** ^Offline* [OR]
RewriteCond %{HTTP_USER_AGENT** ^WebZIP* [OR]
RewriteCond %{HTTP_USER_AGENT** ^WebReaper* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Anarchie* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Mass\ Down* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Slurp* [OR]
RewriteCond %{HTTP_USER_AGENT** ^BlackWidow* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Web********* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Wget* [OR]
RewriteCond %{HTTP_USER_AGENT** ^WebHook* [OR]
RewriteCond %{HTTP_USER_AGENT** ^Teleport*
# adblocking software
RewriteCond %{HTTP_USER_AGENT** ^.*Ad.*Muncher.*v4.*.* [NC,OR]
RewriteCond %{HTTP_USER_AGENT** ^.*NetCaptor.* [NC,OR]
RewriteCond %{HTTP_USER_AGENT** ^.*WebWasher.* [NC]
RewriteCond %{HTTP_USER_AGENT** ^.*adsubtract.*$ [NC,OR]
#Block email collectors
RewriteCond %{HTTP_USER_AGENT** ^EmailSiphon [OR]
RewriteCond %{HTTP_USER_AGENT** ^EmailWolf [OR]
RewriteCond %{HTTP_USER_AGENT** ^ExtractorPro [OR]
RewriteCond %{HTTP_USER_AGENT** ^Mozilla.*NEWT [OR]
RewriteCond %{HTTP_USER_AGENT** ^Crescent [OR]
RewriteCond %{HTTP_USER_AGENT** ^CherryPicker [OR]
RewriteCond %{HTTP_USER_AGENT** ^[Ww]eb[Bb]andit [OR]
RewriteCond %{HTTP_USER_AGENT** ^WebEMailExtrac.* [OR]
RewriteCond %{HTTP_USER_AGENT** ^NICErsPRO [OR]
RewriteCond %{HTTP_USER_AGENT** ^Telesoft [OR]
RewriteCond %{HTTP_USER_AGENT** ^Zeus.*Webster [OR]
RewriteCond %{HTTP_USER_AGENT** ^Microsoft.URL [OR]
#RewriteCond %{HTTP_USER_AGENT** ^Mozilla/3.Mozilla/2.01 [OR]
RewriteCond %{HTTP_USER_AGENT** ^EmailCollector
# Send leeches and spammers to denied page
RewriteRule ^.*$ /html/access_denied.html [L]
--------------------------------------

I'm not very experienced with .htaccess files, so maybe I'm doing something wrong.

After loading this file to my web server, I installed Ad Muncher 4.21. I was able to go to my site and my access was not blocked. Am I doing something wrong? I have other .htaccess files in subdirectories on my site for other uses that work fine. So I'm not sure why this one is not working.

When I filled out a web form on my site to see if Ad Muncher was the HTTP_USER_AGENT I got the following:
HTTP_USER_AGENT: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

So maybe my .htaccess file is OK and Ad Muncher is some how hiding it's self from showing up as HTTP_USER_AGENT?

Has any one else tried testing this with the latest version of Ad Muncher?

UPDATE: I just went to Manos's site and was not blocked. So I know it must not be my .htaccess file. The Ad Muncher folk have found a work around to prevent .htaccess from blocking them....

Last edited by darnell; 07-29-2001 at 06:50 PM.
darnell is offline